BROWSE A-Z
All 305,250 crates, alphabetically
Data as of 2026-07-25 (crates.io database dump, timestamp 2026-07-25T02:00:36Z). Source: crates.io · db-dump.tar.gz · methodology & corrections.
jj-hunkProgrammatic hunk selection for jj174MIT
jj-libLibrary for Jujutsu - an experimental version control system227,869Apache-2.0
jj-lib-proc-macrosProc macros for the jj-lib crate213,522Apache-2.0
jj-lspLSP to resolve conflicts in the jj-vcs864MIT
jj-naviWorkspace navigation and management for Jujutsu, built for parallel human and AI agent workflows.240MIT
jj-ryuStacked PRs for Jujutsu with GitHub/GitLab support224MIT
jj-sliceA semantic stack slicer for Jujutsu.18MIT OR Apache-2.0
jj-spice-cliCLI for jj-spice — stacked change requests for Jujutsu VCS94Apache-2.0
jj-spice-libCore library for jj-spice — stacked change requests for Jujutsu VCS158Apache-2.0
jj-starshipUnified Git/JJ Starship prompt module884MIT
jj-status-parserTODO630MIT OR Apache-2.0
jj-tandemjj workspaces over the network — one server, many agents, real files146MIT
jj-trackA JJ workspace-based task and TODO management CLI tool12MIT
jj-versionCompile-time version strings from Jujutsu metadata23MIT
jj-version-macroProc macro for jj-version37MIT
jj-vineStacked pull requests for jj (jujutsu). Supports GitLab and bookmark-based flow.323MIT
jjaswiss army knife for chess file formats88,526GPL-3.0-or-later
jjarpack up json in a jar1,913GPL-3.0-only
jjcReserved1,867MIT
jjfFuzzy revision picker for jujutsu (jj). Wraps any jj subcommand with an interactive picker over jj log, with a live jj show…57MIT
jjgiA linter/formatter wrapper for jj fix90MIT
jjikLR(1) parser generator464MIT
jjitAI-powered jj version management tool84MIT
jjjDistributed project management and code review for Jujutsu3,046Apache-2.0
jjprManage stacked pull requests in Jujutsu repositories753MIT OR Apache-2.0
jjpwrgemjjpwrgem json parser with really good error messages283MIT
jjpwrgem-lspJSON language server with rich errors252MIT
jjpwrgem-parseJSON parser and formatter with rich errors507MIT
jjpwrgem-schemaJSON schema validator128MIT
jjpwrgem-uirenders jjpwrgem diagnostics333MIT
jjrLocal terminal review surface for jj stacks generated by an agent35MIT OR Apache-2.0
jjsonJSON for rust without NULL1,824MIT
jjsrA fun game where you guess what number the computer has chosen.22MIT OR Apache-2.0
jjss_tocargotest crate repo8,902MIT
jjwtjujutsu-backed worktrunk-compatible workspace manager68MIT
jkA jj-native terminal UI for Jujutsu3,979MIT OR Apache-2.0
jk-cliCommand-line entry points and jj integration helpers for jk236MIT OR Apache-2.0
jk-coreCore state and integration contracts for jk314MIT OR Apache-2.0
jk-cosmwasm-std(Modified) Standard library for Wasm based smart contracts on Cosmos blockchains1,685Apache-2.0
jk-tuiRatatui views and interaction state for jk239MIT OR Apache-2.0
jk-tui-baseScaffold for interactive terminal applications (TUI) based on tokio.1,594MIT
jk_bmsAsync library and CLI (jktool) for JIKONG (JK) Battery Management Systems over Serial, Bluetooth LE and CAN157MIT
jkcenumRust enum library8,139MIT OR Apache-2.0
jkcenum_deriveRust enum library8,659non-standard
jkcliAn opinionated and helpful CLI library1,887MIT
jkconfigA Ratatui-based TUI component library for JSON Schema configuration131,941MIT OR Apache-2.0
jkcursorA custom cursor implementation30MIT
jkipsecUserspace IKEv2/IPsec VPN responder for terminating iOS VPN tunnels and exposing the inner IP traffic. Pairs with jktcp for a…32MIT
jklAsset compression and packing tool1,183MIT OR Apache-2.0
jkl-langOpen Source Programming Language2,857Apache-2.0
jkn_rustClient Rust untuk bridging API BPJS/JKN44MIT
jksJava KeyStore (JKS) and PKCS12 encoder/decoder for Rust25,062MIT
jks-guessing-gameA fun game where you can what number the computer has chosen.699MIT OR Apache-2.0
jktcpA userspace TCP stack that runs over any async read/write transport8,998MIT
jlAn experiment engine742MIT
jl-sysjl-sys contains the generated bindings for the Julia C API used by jlrs.54,951MIT
jl-ui-procmacroProcedural macros for jl_UI, providing code generation and compile-time utilities91GPL-3.0
JL_IA7Getting datas from GPS2,610MIT
jl_UIA Rust UI library using XML for layout and supporting 2D/3D rendering18GPL-3.0
jlabelHTS-style full-context label structure and parser/serializer from/to string124,485BSD-3-Clause
jlabel-questionHTS-style full-context label question parser and matcher11,938BSD-3-Clause
jlcpcb-to-parquetA tool to convert JLCPCB Parts Library to Parquet13,650MIT
jlekLexer generator830MIT
jlensJSON query combinator library5,072BSD-2-Clause
jlessA command-line JSON viewer31,588MIT
jlfCLI for converting JSON logs to human-readable format19,169MIT OR Apache-2.0
jlf-coreEngine for jlf: zero-copy JSON parsing and template-based log formatting28MIT OR Apache-2.0
jlf-itInteractive command builder for jlf: assemble a filter/view/summary/table step by step, preview it, then run or save it as a…17MIT OR Apache-2.0
jlf-tuiInteractive terminal UI for jlf: live-tail, filter, inspect, and summarize JSON logs17MIT OR Apache-2.0
jlibA lightweight blockchain lib.18,061MIT/Apache-2.0
jlifA fast CLI tool for processing and formatting JSON data from streaming input sources42MPL-2.0
jlink_rttImplements the JLINK RTT protocol85,499BSD-3-Clause
jlizard-simple-threadpoolA simple, lightweight threadpool implementation1,146Unlicense
jloA CLI tool for reading, pretty-printing, and colorizing JSON log files (NDJSON/JSON Lines), with protocol-specific formatting for…215EUPL-1.2
jlogJSON logs formatter9,755MIT
jloggerA simple log utility.14,428MIT OR Apache-2.0
jlogger-tracingA simple log utility.13,706MIT OR Apache-2.0
jlotCommand-line tool for JSON-RPC 2.0 over JSON Lines over TCP9,845MIT
jlouCommand-line tool for JSON-RPC 2.0 over JSON Lines over UDP24MIT
jlqQuery JSON log files quickly and efficiently with the power of SQLite1,971MIT
jlrsjlrs provides bindings to the Julia C API that enable Julia code to be called from Rust and more.59,763MIT
jlrs-compatDefines compatible and stable versions of Julia supporte by jlrs2,326MIT
jlrs-derivejlrs-derive contains the custom derives offered by jlrs.8,898MIT
jlrs-launcherA juliaup-aware launcher for projects that use jlrs343MIT
jlrs-macrosjlrs-macros contains the custom derives offered by jlrs.18,989MIT
jlrs-ndarrayjlrs is a library built around bindings to the Julia C API that enables Julia code to be called
from Rust. jlrs can move many…5,843MIT
jlrs-sysLow-level extensions to the Julia C API1,855MIT
jlsImplementation of the simple JSON Licensing Scheme for issuing and/or verifying licenses1,783MIT
jluCommand-line utilities for on-the-fly investigation of JSON Lines1,450MIT
jlucktay-grrsA tool to search files2,776Unlicense
jm_artA simple art generator1,539MIT OR Apache-2.0
jmapJMAP parser/generator9,698MIT
jmap-backup-rsBackup email from a JMAP account to local .eml files20MIT
jmap-base-clientRFC 8620 JMAP base client — auth-agnostic, session fetch, blob, SSE, WebSocket396MIT OR Apache-2.0
jmap-calendars-clientJMAP Calendars HTTP client — extension trait over jmap-base-client118MIT OR Apache-2.0
jmap-calendars-serverJMAP Calendars method handlers — backend-agnostic, plugs into jmap-server Dispatcher66MIT OR Apache-2.0
jmap-calendars-typesJMAP Calendars extension data types (draft-ietf-jmap-calendars-*)191MIT OR Apache-2.0
jmap-chat-clientJMAP Chat HTTP client — auth-agnostic, WebSocket and SSE support47MIT OR Apache-2.0
jmap-chat-serverJMAP Chat extension method handlers — backend-agnostic, plugs into jmap-server Dispatcher67MIT OR Apache-2.0
jmap-chat-typesJMAP Chat extension data types (draft-atwood-jmap-chat-*)119MIT OR Apache-2.0
jmap-cid-typesJMAP Blob Content Identifiers extension data types (draft-atwood-jmap-cid-00)380MIT OR Apache-2.0
jmap-clientJMAP client library for Rust64,110Apache-2.0 OR MIT
jmap-codecjmap-codec1,547EUPL-1.2
jmap-contacts-clientJMAP Contacts HTTP client — extension trait over jmap-base-client117MIT OR Apache-2.0
jmap-contacts-serverJMAP Contacts method handlers — backend-agnostic, plugs into jmap-server Dispatcher67MIT OR Apache-2.0
jmap-contacts-typesJMAP Contacts extension data types (RFC 9610)191MIT OR Apache-2.0
jmap-filenode-clientJMAP FileNode HTTP client — extension trait over jmap-base-client50MIT OR Apache-2.0
jmap-filenode-serverJMAP FileNode method handlers — backend-agnostic, plugs into jmap-server Dispatcher63MIT OR Apache-2.0
jmap-filenode-typesJMAP FileNode extension data types (draft-ietf-jmap-filenode-*)117MIT OR Apache-2.0
jmap-jscalendar-typesJSCalendar (RFC 8984) typed sub-types for the jmap-* crate family265MIT OR Apache-2.0
jmap-jscontact-typesJSContact (RFC 9553) typed sub-types for the jmap-* crate family193MIT OR Apache-2.0
jmap-mail-clientRFC 8621 JMAP for Mail client — Email, Mailbox, Thread, Identity, EmailSubmission methods144MIT OR Apache-2.0
jmap-mail-serverRFC 8621 JMAP for Mail method handlers — backend-agnostic, plugs into jmap-server Dispatcher80MIT OR Apache-2.0
jmap-mail-typesRFC 8621 JMAP for Mail data types (Mailbox, Thread, Email, Identity, EmailSubmission, SearchSnippet)245MIT OR Apache-2.0
jmap-metadata-clientJMAP Object Metadata extension client — Metadata/get/changes/set/query/queryChanges method bindings (draft-ietf-jmap-metadata-01)37MIT OR Apache-2.0
jmap-metadata-serverJMAP Object Metadata method handlers (draft-ietf-jmap-metadata) — backend-agnostic, plugs into jmap-server Dispatcher49MIT OR Apache-2.0
jmap-metadata-typesJMAP Object Metadata extension data types (draft-ietf-jmap-metadata-*)92MIT OR Apache-2.0
jmap-mimeMIME-to-JMAP adapter: converts mime_tree parsed output to jmap-mail-types body structures63MIT OR Apache-2.0
jmap-open-client-libOpen, extensible JMAP client for Rust17AGPL-3.0-or-later
jmap-serverBackend-agnostic JMAP server framework (RFC 8620): parsing, ResultReference resolution, and Dispatcher318MIT OR Apache-2.0
jmap-sharing-clientJMAP Sharing HTTP client — extension trait over jmap-base-client (RFC 9670)49MIT OR Apache-2.0
jmap-sharing-serverJMAP Sharing method handlers (RFC 9670 Principal/ShareNotification) — backend-agnostic, plugs into jmap-server Dispatcher63MIT OR Apache-2.0
jmap-sharing-typesJMAP Sharing data types — Principal and ShareNotification (RFC 9670)118MIT OR Apache-2.0
jmap-tasks-clientJMAP Tasks HTTP client — extension trait over jmap-base-client48MIT OR Apache-2.0
jmap-tasks-serverJMAP Tasks method handlers — backend-agnostic, plugs into jmap-server Dispatcher61MIT OR Apache-2.0
jmap-tasks-typesJMAP Tasks extension data types (draft-ietf-jmap-tasks-*)114MIT OR Apache-2.0
jmap-toolsJMAP object parser with JSON Pointer querying and patching support22,427Apache-2.0 OR MIT
jmap-typesShared JMAP wire types (RFC 8620) for the jmap-* crate family863MIT OR Apache-2.0
jmaplethe red rust rewrite of cbonsai inspired by my dads japanese red maple tree1,509MIT
jmaxMath-native programming language replacing MATLAB / Julia / R / Mathematica. Stub installer; `cargo binstall jmax` fetches the…19non-standard
jmaxmlA parser for JMA (Japan Meteorological Agency) XML format files5,800MIT OR Apache-2.0
jmbgJMBG (Unique Master Citizen Number) used in former Yugoslavian countries6,182GPL-3.0-or-later
jmblA high performance CRDT20,573CC-BY-NC-ND-4.0
jmc-toolsUtils for Rust daily coding.4,434MIT
jmdictThe free Japanese dictionary database JMdict, pre-digested for use in Rust libs and apps.14,426Apache-2.0
jmdict-enumsAutogenerated enums for the jmdict crate. Do not import directly.15,685Apache-2.0
jmdict-fastBlazing-fast Japanese dictionary engine with FST-based indexing557MIT
jmdict-fast-ffiFFI-agnostic facade over jmdict-fast (designed for uniffi, flutter_rust_bridge, bolt-ffi, etc.)64MIT
jmdict-furiganaGenerate Japanese furigana for headword/reading pairs via JmdictFurigana676MIT OR Apache-2.0
jmdict-loadjmdict-rs dependency responsible for retrieving dictionary data2,074Apache-2.0
jmdict-rsSimple interface for interacting with JMdict Japanese dictionary4,062Apache-2.0
jmdict-traverseBuild system support for the jmdict crate. Do not import directly.15,350Apache-2.0
jmemoA simple CUI tool for maintaining memos4,094MIT OR Apache-2.0
jmespatchRust implementation of JMESPath, a query language for JSON52,033MIT
jmespathRust implementation of JMESPath, a query language for JSON2,585,977MIT
jmespath-macrosStatically compiles JMESPath expressions.3,977MIT
jmespath-nativeA rustier JMESPath1,649MIT
jmespath_communityJMESPath is a query and transformation language for JSON6,680Apache-2.0
jmespath_extensionsExtended functions for JMESPath queries - 400+ functions for strings, arrays, dates, hashing, encoding, geo, and more3,235MIT OR Apache-2.0
jmfmJMFM (Java minecraft:filled_map's) is a library and console utility designed to convert images into Minecraft map art6,436BSD-3-Clause
jmix-rsRust library for JMIX (JSON Medical Interchange) format - secure medical data exchange with cryptographic features1,322MIT
jmj_minigrep这是荆明基的字符串查找项目1,655MIT
jmon-rsA zero-copy, cross-platform JVM monitoring library (similar to jstat) in Rust.56Apache-2.0
jmpJamie's Macro Processor1,624MIT
jmp-rsGreat for jumping around!1,872MIT
jmp-scapeSafe Rust access to setjmp and sigsetjmp, forked from cee-scape.38MIT OR Apache-2.0
jmphashAn implementation of the jump consistent hash algorithim2,602MIT
jmplnA tiny, ergonomic function patching crate focused on simple setup and RAII safety.311MIT
jmrA simple library that exports a jmr variable474MIT
jmseJSON Message Signing and Encryption (JMSE)1,848Apache-2.0
jmspack-rustRust crate of functions that James finds useful.1,575BSD-3-Clause
jmtJellyfish Merkle Tree438,921Apache-2.0
jmt-blake3Jellyfish Merkle Tree based on BLAKE3 hash function4,063Apache-2.0
jmt-pqPQ Jellyfish Merkle Tree438Apache-2.0
jmtreea placeholder1,620Apache-2.0/MIT
jmxJMX client library for Rust11,714MIT OR Apache-2.0
jnA simple journaling app. Entries are saved under $HOME/.journal/{user}/{year}/{month}/{day}.json1,923MIT
jnanaJnana — the foundation of knowing. Unified knowledge system for AGNOS35GPL-3.0-only
jnatA wrapper around the jni crate33,173MIT
jnat-macrosCompanion crate for jnat3,278MIT
jnc_auth_serviceTest of cargo publishing an auth service1,544MIT
jniRust bindings to the JNI147,153,325MIT OR Apache-2.0
jni-android-sysAutogenerated glue code for access Android JVM APIs from Rust13,235MIT OR Apache-2.0
jni-bindMade importing classes from java easy7,268MIT
jni-bindgenCode generator for binding to JVM APIs from Rust11,898MIT OR Apache-2.0
jni-bindgen-reflectionStatic reflection APIs for analyzing jars2,800MIT OR Apache-2.0
jni-glueManually written glue code to accompany the jni-bindgen code generator for binding to JVM APIs from Rust55,097MIT OR Apache-2.0
jni-glue-macrosProc macros to implement Java classes from Rust1,782MIT OR Apache-2.0
jni-macrosProcedural macros for the jni crate14,947,052MIT OR Apache-2.0
jni-mangleMangle Rust functions for use with JNI3,952GPL-3.0
jni-min-helperMinimal helper for `jni-rs`, supporting dynamic proxies, Android dex embedding,
permission request and broadcast receiver. Used…36,666MIT OR Apache-2.0
jni-pointerLeaks a value and returns a pointer as a number, so that it can be recovered later, this is useful for JNI objects.1,568MIT
jni-simpleSimple Rust binding for JNI (Java Native Interface) and JVMTI (JVM Tool Interface)28,334MIT OR Apache-2.0
jni-sysRust definitions corresponding to jni.h135,133,475MIT OR Apache-2.0
jni-sys-macrosMacros for jni-sys crate25,836,777MIT OR Apache-2.0
jni-sys-newRust definitions corresponding to jni.h - updated for new Java versions1,654MIT/Apache-2.0
jni-toolboxtools to make writing JNI native functions less tiresome10,246GPL-3.0-only
jni-toolbox-macroproc macro to automate making JNI extern functions10,915GPL-3.0-only
jni-utilsExtra Utilities for JNI in Rust577,964BSD-3-Clause
jni_fnJNI-compatible method signature generator221,097MIT OR Apache-2.0
jni_helperjava function descriptor generate4,584MIT
jni_macroA macro library for simplifying JNI code generation in Rust, enabling easy execution of Rust code in Java.2,431non-standard
jnima jni binding.2,799MIT
jnim_genandroid bind generater base on jnim.2,375MIT
jnim_sysjni binding for jnim.2,541MIT OR Apache-2.0
jninameJava method signature to C-style JNI function name converter718MIT
jninoJava Native Interface to rust Native Objects2,918MIT/Apache-2.0
jnisafeRuntime wrapper types for safe Rust/Java JNI pointer handles (JOwned, JRef, JMut).50MIT OR Apache-2.0
jnisafe-checkStatic checker that verifies a Rust/Java JNI layer agrees on names, signatures, and pointer types.50MIT OR Apache-2.0
jnixHigh-level extensions to help with the usage of JNI in Rust code260,959Apache-2.0 OR MIT