BROWSE A-Z
All 305,250 crates, alphabetically
Data as of 2026-07-25 (crates.io database dump, timestamp 2026-07-25T02:00:36Z). Source: crates.io · db-dump.tar.gz · methodology & corrections.
jshellJSH is a sandboxed shell that input and output JSON (which is handy)3,715GPL-3.0
jshiftSchema-guided typed JSON on raw bytes: path get/mutate, open views, project — without a Value tree.145MIT OR Apache-2.0
jshift-deriveProcedural derive macros for jshift: JsonView / JsonMutatorSchema on raw JSON bytes.190MIT OR Apache-2.0
jshiohaha-newworld-testCreated with Anchor16,775AGPL-3.0
jsiWrite React Native JSI modules in Rust6,838MIT
jsi-macrosSupport macros for jsi-rs5,596MIT
jsi-rsRust bindings to JSI (JavaScript Interface) using cxx27MIT
jsi-sysLow-level interface to React Native JSI6,986MIT
JskDictIn memory Key value database (Based on rust in action book).1,683MIT
jslJSON Schema Language validator and utilities.17,637MIT
jsltEveryones favorite xslt but for json5,028MIT
jslt-macromacro crate for internal use of jslt967MIT
jsmJay's stupid macros1,684MIT
jsmeldA Rust wrapper around SWC for JavaScript/TypeScript compilation and bundling103Apache-2.0
jsmnA minimalistic JSON parser20,101MIT
jsmn-rsBindings and Rustic interface to the jsmn C library for JSON parsing3,396MIT
jsmokeA simple project manager targeting java applications90MIT
jsmoke_applicationJSmoke application use cases126MIT
jsmoke_cliJSmoke CLI parser and application implementer122MIT
jsmoke_macrosJSmoke personal macros173MIT
jsmoke_utilsJSmoke program utilities124MIT
jsmpiA browser-oriented MPI compatibility layer for Rust/WASM using Web Workers70MIT
jsmxPubSub Message Passing for Rust with JSON18,398MIT OR Apache-2.0
jsnA library for querying streaming JSON tokens43,949MIT
jsn-baseA database, similar to `sqlite`. It supports reading and writing.1,528MIT
jsnomSmall and ergonomic JSON parser library2,757MIT OR Apache-2.0
jsnparRust JSON parser implementation using parser combinators.50MIT
jsoNo-BS, no-bloat json library.97GPL-3.0-only
jsobfCLI JSON Obfuscator869MIT
jsodeSimple, zero-copy & zero-dependency JSON Parser6,242MIT
jsode_macroprovide ultilities macro for jsode crate2,297MIT
jsompiler(--> jsonpiler)12,221Apache-2.0
jsompiler_commonCommon utilities for jsompiler2,058MIT
jsompiler_lexerLexer for JavaScript2,341MIT
jsonJSON implementation in Rust23,979,643MIT/Apache-2.0
json-2-yamlcli tool to convert json to yaml52MIT
json-apiIdiomatic types for building a robust JSON API12,265MIT/Apache-2.0
json-api-rocketRocket support for the json-api crate8,430MIT/Apache-2.0
json-archiveCLI tool for tracking JSON file changes over time using delta-based archives78AGPL-3.0
json-array-streamIncrementally reads a JSON array through an async stream1,623non-standard
json-bookBook format optimized for small screens, an alternaive for the XML-based FB23,292MIT
json-bourneType-driven JSON parser. no_std-first. Zero-dep.270MIT
json-builder-macroA lightweight macro for generating JSON objects1,117MIT
json-cjson-c1,720MIT
json-canonSerialize JSON into a canonical format.456,598Apache-2.0
json-carverDigital forensics tool that reads (carves) JSON strings from a dump. Think of it
as a more accurate and faster replacement for…428MIT OR Apache-2.0
json-centerA database, similar to `sqlite`. It supports reading and writing.45GPL-2.0
json-checkera wrapper around JSON-c3,265MIT/Apache-2.0
json-cliHelpers for creating CLIs with serializable JSON output.6,941Apache-2.0
json-codecJSON Codec implementation43,027non-standard
json-codec-wasmJSON Codec implementation, CosmWasm compatible10,666non-standard
json-colorColorize JSON strings45,088MIT
json-colorizerA fast, lightweight JSON formatter, pretty-printer, colorizer, and query tool for Rust — with jq-style dot-path queries60MIT
json-commonsA set of JSON common tools in Rust7,354Apache-2.0
json-compareJSON comparison3,292MIT
json-compare-cliA command-line tool to compare JSON files and print the differences in a human-readable format.2,288GPL-2.0
json-crawlerWrapper for serde_json that provides nicer errors when crawling through large json files.14,125MIT
json-dbSimple library for a document database saved on disk3,944Apache-2.0
json-decodeAn elm inspired runtime JSON decoder for Rust292,439MPL-2.0
json-deserializerPerformant library to deserialize JSON1,134,690Apache-2.0
json-digestAllow selective masking of JSON subdocuments for privacy, preserving the digest of the whole document.22,398LGPL-3.0-or-later
json-digest-wasmWebAssembly wrappers for the json-digest crate.4,302LGPL-3.0-or-later
json-eA data-structure parameterization system for embedding context in JSON objects18,274MPL-2.0
json-elemManage JSON string as element.9,873MIT
json-escapeA no_std, zero-copy, allocation-free library for streaming JSON string escaping and unescaping. Ergonomic, fast, RFC 8259…23,455MIT
json-escape-cliA CLI tool to JSON-escape strings read from stdin25MIT
json-escape-simdOptimized SIMD routines for escaping JSON strings.1,710,699MIT
json-eval-rsHigh-performance JSON Logic evaluator with schema validation and dependency tracking. Built on blazing-fast Rust engine.1,544MIT
json-event-parserA JSON event parser and serializer701,416MIT OR Apache-2.0
json-event-parser-witespaceA json event parser with whitespace2,760MIT
json-extThis library provides an extension object for serde_json crate.6,628MIT OR Apache-2.0
json-extractorHigh-performance two-stage JSON fragment scanner with SIMD acceleration22MIT OR Apache-2.0
json-ezThis crate is a wrapper around serde and serde_json crates. It does not aim to replace those two awesome crates, the goal is to…2,681MIT
json-feed-modelJSON Feed model5,254MIT OR Apache-2.0
json-filterA library for filtering JSON values using simple query structs / enums5,226Apache-2.0 OR MIT
json-firestore-seedA simple high-performance CLI tool to bulk-insert documents into Google Firestore from a JSON file.21MIT
json-fiveJSON5 parser with round-trip capabilities and compatible with the serde data model776,189MIT
json-fixRobust JSON repair engine for fixing malformed or partial JSON strings, especially from AI output1,013MIT
json-fixerA robust library for fixing and formatting malformed JSON with support for type conversion2,836MIT
json-flat-parserParse JSON document into a flat data structure1,511MIT
json-fmtA cli-tool for formatting json4,281MIT
json-forensicsA crate that adds a read adapter to deal with bad Python caused JSON payloads (NaNs and Infinities)109,039BSD-3-Clause
json-formatter-cliA fast JSON formatter written in Rust32MIT
json-from-wastConversion from `*.wast` files to JSON.905,834Apache-2.0 WITH LLVM-exception OR Apache-2.0 OR MIT
json-genThe simple console utility and library to generate JSON items5,599non-standard
json-generatorCLI tool to generate JSON from simple DSL10,151MPL-2.0
json-generator-randThe simple console utility and library to generate JSON items1,673non-standard
json-gettextA library for getting text from JSON usually for internationalization.114,725MIT
json-glibRust bindings for the Glib Json library77MIT
json-glib-sysFFI bindings for Json Glib536MIT
json-grepA grep-like utility for searching JSON data with regular expressions439MIT OR Apache-2.0
json-highlight-writerjson-highlight-writer is a writer for json-rust object which supports highlighting slices when printing JSON objects7,541MIT
json-job-dispatchDispatch jobs described by JSON files and sort them according to their status.21,956MIT/Apache-2.0
json-joxit-forkJSON implementation in Rust1,821MIT/Apache-2.0
json-key-from-valueFind the key or index that provides a value in a big blob of JSON.1,500MIT
json-key-removerRemove specific keys from json1,616MIT
json-keypath-iterIterator for traversing serde json objects, yielding a flattened path and value of each element.29,456MIT OR Apache-2.0
json-ldJSON-LD implementation510,412MIT/Apache-2.0
json-ld-cliCommand line interface for JSON-LD3,911MIT/Apache-2.0
json-ld-cli-nextCommand line interface for JSON-LD1,100MIT/Apache-2.0
json-ld-compactionJSON-LD document compaction implementation460,464MIT/Apache-2.0
json-ld-compaction-nextJSON-LD document compaction implementation2,648MIT/Apache-2.0
json-ld-context-processingJSON-LD context processing implementation454,047MIT/Apache-2.0
json-ld-context-processing-nextJSON-LD context processing implementation3,037MIT/Apache-2.0
json-ld-coreJSON-LD core types and traits463,575MIT/Apache-2.0
json-ld-core-nextJSON-LD core types and traits3,389MIT/Apache-2.0
json-ld-expansionJSON-LD document expansion implementation460,725MIT/Apache-2.0
json-ld-expansion-nextJSON-LD document expansion implementation2,844MIT/Apache-2.0
json-ld-nextJSON-LD implementation2,663MIT/Apache-2.0
json-ld-serializationJSON-LD serialization205,611MIT/Apache-2.0
json-ld-serialization-nextJSON-LD serialization2,652MIT/Apache-2.0
json-ld-syntaxJSON-LD syntax464,308MIT/Apache-2.0
json-ld-syntax-nextJSON-LD syntax3,584MIT/Apache-2.0
json-ld-testingTesting library for the `json-ld` library39MIT/Apache-2.0
json-ld-testing-nextTesting library for the `json-ld` library620MIT/Apache-2.0
json-lexA zero-copy, iterator-based JSON lexer with span tracking19MIT
json-linesA no_std + serde compatible message library implementing JSON Lines32,138MIT OR Apache-2.0
json-lines-viewerJSON Lines Viewer - Terminal-UI to view app logs available in JSON line format2,928MIT
json-log-parseLog tailer for deployments using JSON log format6,694Apache-2.0
json-mask-fieldsselect/redact subsets of JSON objects via a Google fields-style query language45MIT
json-matcherUtility library for declaratively matching JSON values24,240MIT
json-mcp-serverA high-performance Model Context Protocol (MCP) server for comprehensive JSON file operations optimized for LLM interactions571MIT OR Apache-2.0
json-melMélodium JSON data processing library11,263EUPL-1.2
json-mergeJSON merge helpers for Structured Merge19AGPL-3.0-only OR PolyForm-Small-Business-1.0.0
json-merge-patchImplementation of RFC 7396 - JSON Merge Patch.239,152MIT
json-minimal-testsExtracts minimal tests from the source codes of a repository when
there are differences between the metrics computed before and…12,928MIT
json-modelExtensible framework for validating JSON structures4,110MIT
json-mumuJSON tools and JSON Schema plugin for the Mumu ecosystem2,929MIT OR Apache-2.0
json-mutex-dbRidiculously simple, fast and thread safe JSON file database703Apache-2.0
json-nodeA way to work with JSON as a node tree.5,097MIT
json-nsA subset of JSON-LD1,918MIT
json-numberJSON number parsing and storage3,215,775MIT/Apache-2.0
json-objects-to-csvRobust Rust library for converting JSON objects into CSV rows75,188MIT
json-on-the-flyStore structs in json files on the fly and remove all boilerplate for (de-)serialization64non-standard
json-on-the-fly-deriveA small helper crate for `json-on-the-fly` that provides a derive macro48MIT
json-outersplits tail output into multiple files1,558MIT-0
json-packerReversible JSON binary compression/decompression library with Huffman-encoded keys and optional string value pooling418MIT
json-parseA low-level JSON parser for Rust with a simple API and full spec support.2,345MIT
json-parserJSON parser6,211MIT
json-patchRFC 6902, JavaScript Object Notation (JSON) Patch86,888,382MIT/Apache-2.0
json-patch-cliA CLI command to perform JSON RFC 6902 patching, merging and editing operations5,242MIT
json-patch-extUnofficial extensions and helpers for json_patch32,827MIT
json-peekAmature JSON parser library designed for my specific need3,036MIT
json-pest-parserParse JSON with pest grammar.11,270AGPL-3.0
json-placeholder-dataCopy of the data on https://jsonplaceholder.typicode.com/ used in testing3,170MIT
json-pluckPluck a single value out of a serde_json::Value by dotted path or simple JSONPath. Lossy, forgiving, intended for LLM-emitted…19MIT OR Apache-2.0
json-pointerA crate for parsing and using JSON pointers, as specified in RFC 6901.22,010,416MIT
json-pointer-simdA crate for parsing and using JSON pointers with simd_json, as specified in RFC 6901.8,282MIT
json-pollerA lightweight, flexible, high-performance JSON polling library for Rust.101MIT OR Apache-2.0
json-popA small JSON parser from parser/lexer generators.3,081MIT OR Apache-2.0
json-position-parserA simple json parser with positions.13,136MIT
json-pp-rustReads a string from `stdin` parses it as json and prints it out as a pretty json string.1,599non-standard
json-predicateJSON Predicate lib based on draft-snell-json-0721,132MIT OR Apache-2.0
json-pretty-compactA compact & pretty formatter for serde_json44,067MIT
json-proof-tokenA library implementation based on the new JOSE Working Group draft specifications:
JSON Web Proof (JWP), JSON Proof Token (JPT)…159,496Apache-2.0
json-ptrA crate for parsing and using JSON pointers, as specified in RFC 6901.6,574MIT
json-queryRun jq programs to extract data from json strings.10,575Apache-2.0/MIT
json-readjson-read是一个json读取工具,可以直接通过`x.y.z.w`方式读取json中的内容,不用逐层解析918MIT
json-registerA Rust library for registering JSON objects in PostgreSQL with canonicalisation and caching205Apache-2.0
json-remove-keysRemoves keys from a json file, writing the file after.1,125Unlicense
json-repairA well tested crate for repairing malformed JSON strings and repairing/parsing them into valid JSON values22,188MIT
json-requestMake JSON HTTP requests with automatic de/serialization9,792MIT
json-respA utility to generate easy json response/errors3,931MIT OR Apache-2.0
json-resp-deriveA utility to generate easy json response/errors3,258MIT OR Apache-2.0
json-responseA utility library to send JSON response for Routerify and hyper.rs apps.1,927MIT
json-resultA generic enum representing a JSON result that can either be a success (`Ok`) with a value of type `T` or an error (`Err`) with a…679MIT
json-resumeA library to interact with the jsonresume schema3,466Unlicense
json-rpc-rsA framework-agnostic JSON-RPC 2.0 handler for Rust88MIT
json-rpc-serverA framework for http server3,610MIT OR Apache-2.0
json-rpc-typesType definitions for JSON-RPC135,957BSL-1.0
json-rpc2Simple, robust and pragmatic JSON-RPC 2.0 implementation66,692MIT OR Apache-2.0
json-rsLightweight JSON reader and writer, written in pure rust.2,734AGPL-3.0-only
json-rules-enginejson rules engine29,214MIT/Apache-2.0
json-rules-engine-forkjson rules engine fork139,140MIT/Apache-2.0
json-schema-catalog-rsA tool for managing JSON Schema catalogs as defined by…1,504Apache-2.0
json-schema-deriveJSON Schema derive macro with arbitrary fields support2,248MIT
json-schema-derive-macroProc-macro for JSON Schema generation2,480MIT
json-schema-diffDiff changes between JSON schema files.101,765Apache-2.0
json-schema-dslA simple DSL to write JSON Schema4,377Apache-2.0
json-schema-fakerRust wrapper of JS' `json-schema-faker`23MIT
json-schema-generatorA tool to generate JSON Schema from JSON data2,413MIT
json-schema-rsA Rust library to generate Rust structs from JSON Schema.304non-standard
json-schema-rs-macroProcedural macro json_schema_to_rust! for json-schema-rs135non-standard
json-schema-sortDeterministic, schema-aware sorting for JSON Schema files547Apache-2.0 OR MIT
json-schema-to-luauConvert JSON Schema to Luau type definitions with full support for constraints and advanced schema features.186MIT
json-schema-to-zodGenerate Zod schema source code from JSON Schema48MIT
json-schema-toolsJSON Schema code generation tools for Rust1,878non-standard
json-schema-traverserecursively walk a JSON Schema, invoking pre/post callbacks on each subschema45MIT
json-schema-validator-coreLightning-fast JSON schema validation library with custom error messages and multi-language bindings3,725MIT OR Apache-2.0
json-seqRead & Write json sequences1,291AGPL-3.0+
json-sessionA streaming parser for JSON which emits fragments and location spans from an iterator-style API.863MIT
json-simple-obfuscatorA tool to partially hide json value (using unsecure pseudonimize / obfuscate algo).3,883CC0-1.0
json-sortA command-line tool that sorts JSON files with a consistent key order, making them easier to read and maintain.100EUPL-1.2
json-sourcemapA library for parsing and generating JSON sourcemaps9,264MIT OR Apache-2.0
json-spanned-valueTrack the origin of your json values for better error reporting!872,594Apache-2.0 OR MIT
json-split-aomSplit a large JSON file containing an array of maps into multiple files7,154MIT
json-steroidsBlazing fast JSON serialization and deserialization library, powered by procedural macros.191MIT
json-steroids-deriveMacro crate for json-steroids, providing procedural macros for blazing fast JSON serialization and deserialization.253MIT
json-store-deriveA small helper crate for `json-store` that provides a derive macro19MIT
json-streamA library to parse Newline Delimited JSON values from a byte stream6,755non-standard